PaperMC TPS Problems

  • I have noticed that TPS cannot rise to 20 for me and for my friend on the PaperMC 1.12.2 server. It is in the range of 19.6-19.88 all the time. I tried it on a fully clean server, all the same. I didn't change anything or install anything. I tried several times and the result was the same at all times. TPS was not 20 even when no one was on the server. This is not normal, there was no such thing before

    What is the problem?


    https://timings.aikar.co/?id=8…c592e4c3abd5270ba8133f017

    https://mclo.gs/V6DXXZW

    (In this attempt I did not go to the server, but in the others I was there. It didn't change anything)


    UPD: Not tested on other cores, only on PaperMC 1.12.2.

    UPD2: Also, in timings I noticed that with "TPS Loss 0%", it still shows TPS below 20.

    Edited 2 times, last by 3Lord3 ().

  • 3Lord3

    Changed the title of the thread from “TPS Problems” to “PaperMC TPS Problems”.
  • this is normal, 20 tps is only achieved when having a supercomputer for a server, minecraft rarely runs on 20 tps even on the strongest servers, personally i have never seen a 20 tps server in my life

    Until this day, I only saw 20 TPS on an empty server. This is not normal when nothing happens on the server (I tried to disable mobs spawning and structure generation + kill all mobs and drop) but the server cannot give 20 TPS. Previously, Aternos always showed 20 TPS when there is no reason to load the server.

  • dont forget the older the server the more performance it will use, this is true for all servers, a good example is 2b2t, also 20 tps still cannot be achieved as dont forget there are millions of calculations even when there is nothing visually happening on the server

  • dont forget the older the server the more performance it will use, this is true for all servers, a good example is 2b2t, also 20 tps still cannot be achieved as dont forget there are millions of calculations even when there is nothing visually happening on the server

    I told you, I am using a completely empty and new server. There are no heavy computations on it. There are no plug-ins, nobody generates chunks (the server doesn't even have players), no monsters and animals. There must be at least 20 TPS.

  • Why would that be? Just because you are missing .2 TPS? Just play, if you notice that you are superhuman and can program your own 100TPS software

    Of course I can play this way, but it seems abnormal to me that TPS suddenly stopped holding on 20 on an empty server. This has never happened before

  • Why would you even care about .2 TPS? Paper also got better over the course of the versions, maybe 1.12.2 just isn't as good and oh no they can't do 20.0 but only 19.8. Be happy you get 19.8 and not 9.8

  • which could also be caused by a large amount of mobs nearby

    You have not read what I wrote. The server is completely empty. There is no mob, no drop, no plugin, and even no players on it. That is why it is not normal.I will not answer these meaningless messages anymore, but it is better to wait for the answer of someone responsible for it.

  • Quote from 3Lord3

    I will not answer these meaningless messages anymore

    Likewise, my man. If apparently a loss of .2 TPS makes the game unplayable for you, then I shan't tell you of servers getting only 19 TPS, god forbid

  • hey 3lord3 i understand what you mean and how it feels, this problem is aternos-side and they probably wont fix it, and when the mods tell you they tested it they probably used some type of mod server with better hardware or something, but still it would be better to take the 19.80 tps rather than switching hosts but when it becomes a serious problem you should switch and test which one gets the least serious problem


    personally i got my own hardware for one of my servers as 5 tps is unbearable when loading chunks

  • hey 3lord3 i understand what you mean and how it feels, this problem is aternos-side and they probably wont fix it, and when the mods tell you they tested it they probably used some type of mod server with better hardware or something, but still it would be better to take the 19.80 tps rather than switching hosts but when it becomes a serious problem you should switch and test which one gets the least serious problem


    personally i got my own hardware for one of my servers as 5 tps is unbearable when loading chunks

    To clear this whole useless monstrosity up: Yes, of course it's Aternos-side if the TPS loose, oh god, a single percent. We don't have infinitely good hardware to support 20TPS when doing literally anything. Mobs and exploration can make the TPS go down temporarily, but if you don't constantly fly around with elytra into new chunks and generally stay in explored chunks, TPS will always stay 19.5-20. You cannot possibly feel the difference, it simply makes no sense. If you really want to continue your thing here, paste the spigot timings and check out what's causing this horrible and unplayable lag, and fix it yourself. Yes, YOU, it's your server and only you can do something about it. Personal experience that you will slam to shit because it's from someone else: Citybuild, 10 people, rather big / spread out world, permanently 20TPS, maybe 19.5 when something happens, but usually I read nothing but 20 in the TPS. Your PC also loses FPS constantly, when turning or whatever, are you gonna whine about that too? Get a server and host it yourself if you are such a TPS-phile, Aternos gives you playable servers with easily achievable 20TPS

  • To clear this whole useless monstrosity up: Yes, of course it's Aternos-side if the TPS loose, oh god, a single percent. We don't have infinitely good hardware to support 20TPS when doing literally anything. Mobs and exploration can make the TPS go down temporarily, but if you don't constantly fly around with elytra into new chunks and generally stay in explored chunks, TPS will always stay 19.5-20. You cannot possibly feel the difference, it simply makes no sense. If you really want to continue your thing here, paste the spigot timings and check out what's causing this horrible and unplayable lag, and fix it yourself. Yes, YOU, it's your server and only you can do something about it. Personal experience that you will slam to shit because it's from someone else: Citybuild, 10 people, rather big / spread out world, permanently 20TPS, maybe 19.5 when something happens, but usually I read nothing but 20 in the TPS. Your PC also loses FPS constantly, when turning or whatever, are you gonna whine about that too? Get a server and host it yourself if you are such a TPS-phile, Aternos gives you playable servers with easily achievable 20TPS

    this is not the point of this, the first point i was talking about is how you said you play on a paper citybuild server running 1.16.4 (laggiest version of minecraft to date) with 10 players and most of the time achieve 20 tps when someone with an empty server and no chunks loaded and no mobs no players cant achieve 20 tps, there is a clear difference here, probably to do with mod servers, anyway, the second point is the 5 tps when loading chunks, thats not normal, nothing in the logs, reported it before alot even on the discord, got 0 help, all what i was doing is playing on a paper server alone loading chunks in the overworld by just sprinting normally like any player would do and then i noticed i was rubber banding like heck so i just typed /tps and got the number 5, also its def not my internet, even if it was my internet the tps is the point here not the rubber banding.


    anyway tho i managed to solve this problem by using fabric lithium and phosfor and not updating to the laggiest version of mc (at that time i was running 1.16.1, and even now im limiting myself to 1.16.3 which is a bit less laggy than 1.16.4)


    another thing is on that exact same server i have huge problems in the nether and i explained it in its own thread (its recent so i didnt get a reply yet).


    forgot to mention the fact that my pc stays permanently at 60 fps even when running a benchmark to check for problems (which i explained in the nether problem thread)

  • Sorry I only read to 1.16 is the laggiest there is. I won't read further. 1.13 is the laggiest, by FAR, up until 1.16 they slowly managed to optimize it. I won't read further, don't even try, I know you from Discord and I know what kind of nonsense you give from you. Ok I did read further and all I found was bullshit. There is no such thing as "mod servers", everyone gets the same servers. Now I definitely won't read further, you should at least know your way around stuff before ranting about it and horribly failing so. Your entire post is bs, as is every message you send in Discord

  • Kurt

    Closed the thread.