"Turn Off Your Adblocker" Misfiring

  • I'm having an issue with the website always popping up the "turn off your adblocker", i dont mind ads, nor do i wanna not see them because i know this is how you finance your stuff.

    but, despite switching to over 8 browsers, using a different internet connection, i still get this error (i even tried on a different device). i already checked windows defender on its things but there's nothing on there i need to change. i feel like this could be a bug, cuz i've had some friends report this happening to them too. we dont have an adblocker - and as seen here i can clearly see ads, and they can fill up the screen all they want. but the "turn off your adblocker popup" becomes more of a nuisance than that of ads.

    If im overlooking something please do tell me cuz i dont want this to pop up too much. its more of an ad than the ads themselves. again, i can see the ads but it thinks im using an adblock. i use Opera GX as of now, i tried chrome, edge, firefox, brave, apple's safari, brave, pale moon, vivaldi, yandex, even the vigorous Internet Explorer. none of them fix the "turn off your adblocker" problem, it could be my laptop, but i said again i tried a different device, i tried my friend's laptop, i asked a friend on discord to do everything for me because they dont have the pop up. im starting to think some script is running incorrectly because the adblock detector is misfiring. this didn't happen before and my ISP doesnt block ads as far as i know, because i have two subscribed and 2 routers. and i tried connecting mobile data (which was a bad idea considering laptops eats so much bandwidth) i still get this one pop up.

    You can see here at the bottom of the screen that i'm seeing ads. the X button is there and i can access the ad if clicked. so ads do work, which means the anti adblock is misfiring. idk if anyone else would be having issues, some of my friends also have the same issues.

    thanks in advance for the help
    - AgniumXV

  • I dont think i have one, and the one on Opera GX is turned off.

    Im subscribed to a service called "PLDT" here, thats a service here in the philippines. this hasnt happened before until recently. i do recall a windows update happening but im not sure if that could be the case - its possible because its a windows update, and updates are widespread.


    do you by any chance know if there's a thing or two in windows defender i may have overlooked?

  • thing is, i mentioned using every browser i've come across and i have no adblock at all. i doubt its my internet. just got a new phone the other day, and that one had no problem browsing the aternos website.

    it narrows down to whats on my laptop, i dont have any other antivirus apart from the default windows defender.

  • Did you manage to solve this problem?

  • The issue has seemingly disappeared after our ISP went down with a BIG outage for 4 days- (funnily enough they always time these outages a few days after i pay the bills), i feel like i just got robbed, because they dont advance the next due date to 4 days.


    so i feel like it was on my ISP's end.. because i may have the same company on both routers. and then my sim carrier. it may have been a problem with their company. issue has been fixed. HOWEVER, it does come back from time to time, a simple reload could fix it. or turning my VPN on and then OFF works.


    so if you happen to have a VPN on your thing, try turning it on.


    that explains why when using several devices worked. borrowing wifi from my cousin also worked- though if you care to spend the extra buck to travel.