Keep getting disconnected

  • hi! i recently created a server to play with my 2 friends. Yesterday, I was able to play just fine. There was only the decocraft mod on the server, but my friend's computer couldn't handle it, so i deleted it. I then switched the version of the server to 1.12.2 vanilla (instead of forge). When i woke up the next day, I wasn't able to play at all without getting continuously kicked. I tried deleting the mods on my computer, I'm no longer using optifine, and i even checked my own wifi connection, but nothing is working. My other friends can connect and use the server just fine, but within me being on the server for a couple of seconds, i get kicked. The error message is: Internal Exception: java.io.IOException: Connection reset by peer. It's definitely not a problem with my connection, and i even tried to generate new worlds (and delete the old ones) in order for me to reconnect without getting kicked, but nothing is working.


    If it helps, my location is in Canada, while both of my friends' locations are in the USA. Here's the log to show what's happening:

    [01:11:26] [Server thread/INFO]: petalier joined the game

    [01:11:35] [Server thread/WARN]: Can't keep up! Did the system time change, or is the server overloaded? Running 2102ms behind, skipping 42 tick(s)

    [01:11:51] [Server thread/WARN]: Can't keep up! Did the system time change, or is the server overloaded? Running 3082ms behind, skipping 61 tick(s)

    [01:11:57] [Server thread/INFO]: petalier lost connection: Disconnected

    [01:11:57] [Server thread/INFO]: petalier left the game

  • did you generated new world after deleting decocraft?

    if not try generating new one

  • Share your log:

    1.) Go to your log on Aternos: https://aternos.org/log/

    2.) Click on the big blue "Share" button on the top right

    3.) Copy the link with (Ctrl + C or click on the "Copy" button)

    4.) Send the link here.

  • Roman

    Closed the thread.