Forge server crashes on start due to world using an old forge version

  • I've been playing on a server i created on aternos for quite a while, with many mods and they all work just fine, but some time to time i get this crashing error when i open the server that says "the world was saved with mod "forge" version [X] and now is in the version [Y]". I'm playing in 1.18.1 and the forge version of the world is 39.0.48 at the moment but the server is 39.0.55, it says that i should downgrade to 39.0.48 but aternos doesn't give me that option, it uses the latest version. I've been getting this error for some time and it always seems to fix itself, but there it's still a window of time where i can't play until the fix.


    So the question is: why does this happen? is there something i can do? can i downgrade server forge some way? does it work if i download the world and upload it again or does it not upgrade to latest forge version?


    more importantly is there any way to prevent aternos from upgrading the forge version that works just fine and keep it from crashing my server every week?


    thank you.

  • The server is not crashing due to the forge version. It says

    [13:08:05] [Aternos System/ERROR] [LOG]: Server was stopped because it took too long to start. Try reducing the load to avoid this in the future.

    It looks like the Aternos system system stopped your server because it took too long for it to start. This can happen when a server is overloaded (too many plugins, resource-heavy modpack, etc.). The Aternos system automatically stops servers if they don't respond within a certain amount of time to prevent them from getting stuck during startup. Especially in the afternoon (Central European Time), when many servers run simultaneously, servers running many mods sometimes take too long to start.

    Unfortunately, there is not much that can be done about this. You can only try to start your server again at another time, remove some resources (e.g. plugins/mods).

  • You are right, now i tried opening the server again and again until it finally worked!, now that you mention it i've had this issue before at this same time of the day, so a servers overload due to many servers opening and many mods being loaded is crashing it.

    Thank you very much, it helped a lot!