incompatible fml modded server server network message list is not compatible message keeps appearing, dont know how to fix

  • I keep getting this "incompatible fml modded server server network message list is not compatible" error when trying to join my multiplayer server, the only mods we're using are mrcrayfish's furniture mod and optifine for shaders (robobo1221). This worked on client side before but now it's suddenly giving me this error. I checked other threads but I don't understand what the issue is and how to fix it, and I'm not very good at computers or understanding them. I'm pretty sure everything is the same version so I don't understand why this is happening. Please help me