Preparing spawn area: 82% until it crashes bc it took too long

The Aternos forums are now deprecated

Learn more about this change here.

For help regarding Aternos, we recommend you to visit our support center.

  • I have a bit of a unique issue. I was playing with a friend on a modpack available on aternos, RAD2, but it kept updating, and we couldn't turn that off. It was also being discontinued, as it was no longer supported or showed up on the modpacks list. Eventually, the updates got more game-changing and a little game-breaking, and we decided we wanted to restore the world to before the latest update and then play only on that one. I thought a lot about how to do this, and i decided that the most plausible way would be to assemble from scratch the mod list from that update in aternos, and copy over the world file. I've done this. There were a few mods I could not add which had been present, which "did not allow project distribution" or "could not be added due to technical reasons." This list includes Better Default Biomes, KubeJS, Connectivity, Oauth, "Mining Dimension," and Magical Jewelry. I wasn't sure if the removal of these would be game breaking to the world, but I decided to try. Also not in the mods folder are all of the mods aternos says are client-side, which the logs say after the first crash the world was saved with, which I found strange. These number ~6. The log for a first launch is here, and includes the error list.
    Our world worked just fine with this mod list when i loaded it up in singleplayer, and most or all of the structures and items seemed to be fine. I uploaded the world to the server, and launched it. It took a very long time and after taking too long, it crashed. It had repeated the "Preparing spawn area: 82%" message 18 times before crashing. When I tried it again, it repeated 82% a few times, and then progressed to 95% before repeating that until it (took too long) crashed again, which was a lot more than 18.

    I tried again regenerating with a new world, and was not successful either time it launched, the log for which is here:

    I'm considering removing Tropicraft and smallships which seem to be throwing the last errors that it spent so long on, but it also seems like a lot of other things are throwing errors too, even things that don't refer to any specific mod.

    I copied over most of the files in the config folder i have for the modpack version i wanted, but I left some out, as I couldn't find a way to do them all at once and so I went one by one until i got bored of it. it seems to have generated the others on its own, so it's possible I messed something up by doing this.

    I spent four or five hours putting this together as precisely as I could, and I really want it to work, but I also understand that I chose a,,, perhaps unwise hill to die on. This modpack is huge and at its best, shoddily put together. I would like to say that on our server, it was running just fine, with minimal lag, and a good experience. I wish there was some way to turn off the updates, or some way to appeal the decision to stop supporting this modpack. It was running very well the way it was, and in ~30 hours of playtime only crashed on us two or three times.

    I think that's everything. i didn't save the first few logs, but the results seemed about the same. I didn't get the Server Thread/FATAL the first few times, though.
    Any help or advice would be very appreciated. This world is very dear to us. Thanks for reading!

  • I, and i'm sure several other helpers beg you to summarize this next time.

    Assuming you mean Roguelike Adventures and Dungeons 2 with RAD2, this was removed because we could never ensure a reasonable experience of playing it due to the large amount of resources it required. This, also being the reason why you can't do that by having each mod seperately installed - which is probably even less optimized than the modpack itself. With that said, it is simply not plausible to run this modpack on a limited host like Aternos.