GeyserMC Plugin corrupted

  • Today I updated the GeyserMC plugin for my server but the server failed to load it. This error message popped out instead:

    Code: log
    Could not load 'plugins/Geyser-Spigot.jar' in folder 'plugins' org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml

    I tried reinstalling the plugin, yet it failed.
    Then, I went and contacted GeyserMC support, they replied:

    After that, I hosted my own PaperMC server with GeyserMC on my laptop. Turns out it worked flawlessly. So, it isn't an issue with the plugin GeyserMC provided. I then found out through the Discord server that many of us are also getting the same issue. So conclusion, it's an issue with the plugin provided by Aternos :aternos: .


    Right now, we can only install the latest GeyserMC plugin whether it's corrupted or not. Thus, I hope that there we are able to install previous versions of GeyserMC so that we won't need to wait till the next update for it to be fixed.

  • Roman

    Closed the thread.