Can not join my own server at times

The Aternos forums are now deprecated

Learn more about this change here.

For help regarding Aternos, we recommend you to visit our support center.

  • I can join my own server only about half the time. The other half I am stuck on "pinging" when I refresh the page in multiplayer. And when I try to join it, I either time out, or get stuck on the "encrypting" phase and then it tells me "couldn't connect to the server", or "lost connection".

    I've sometimes seen my name popping up on the log too that I am trying to join several times, and then it says I timed out.

    I've tried the DynIP too many times, it never worked.

    I've tried reinstalling my client, the server, deleting it, and remaking it, flushing my dns, fully turned off my firewall, and it doesn't make any difference whatever I do. It always comes back to this that it randomly decides to not let me in and then suddenly it lets me in, and then it stops again for a while. But my friend is playing on the server while I can't join.

    But this thing has happened to my friend too a few times. I was playing, and my friend wasn't able to join. But this seems to happen to me every day and way more than it happens to her. The server just randomly stops responding to my attempts to communicate with it. And yes, I always make sure the server is online before trying to join it.

    I can even successfully ping both the static and DynIP with command prompt and none of the packets are lost.

    Then I decided to open in chrome while the server is online to see if it opens it, and it didn't. So chrome told me to run windows network diagnostics on it, so I did, and it told me that the server is online and is just not responding on port 80 for some reason.

    I'm running Fabric 1.17.1 (0.12.1) by the way.