Server will kick players and shut down.

The Aternos forums are now deprecated

Learn more about this change here.

For help regarding Aternos, we recommend you to visit our support center.

  • My problem is that I made a custom super flat world on single player, after I did that I created a server to use world edit, other plugins and to be able to play with my friends. But yesterday when I was in the middle of playing I disconnected some how. When I went to the server page the server was stopping. I didn't think much of it so I started the server up again and tried playing. I was in game for about 5 seconds before I was disconnected and the server shut down, here is the console.

    [20:34:18] [Server thread/INFO]: [ClearLag] Enabling ClearLag v2.9.7
    [20:34:19] [Server thread/INFO]: [ClearLag] Loading modules...
    [20:34:19] [Server thread/INFO]: [ClearLag] Modules enabed, loading config values
    [20:34:19] [Server thread/INFO]: [ClearLag] Modules have been loaded!
    [20:34:19] [Server thread/INFO]: [ClearLag] Clearlag is now enabled!
    [20:34:19] [Thread-7/INFO]: [ClearLag] Checking for updates compatible with your bukkit version [1.8]...
    [20:34:19] [Server thread/INFO]: [WorldEdit] Enabling WorldEdit v6.1;no_git_id
    [20:34:21] [Server thread/INFO]: WEPIF: Using the Bukkit Permissions API.
    [20:34:22] [Server thread/INFO]: [WorldEdit] Using com.sk89q.worldedit.bukkit.adapter.impl.Spigot_v1_8_R3 as the Bukkit adapter
    [20:34:22] [Server thread/INFO]: [Shopkeepers] Enabling Shopkeepers v1.86
    [20:34:23] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
    [20:34:23] [Server thread/INFO]: Done (10.864s)! For help, type "help" or "?"
    [20:34:23] [Server thread/INFO]: Starting GS4 status listener
    [20:34:23] [Query Listener #1/INFO]: Query running on
    [20:34:24] [Thread-7/INFO]: [ClearLag] No updates found!
    [20:34:41] [Server thread/INFO]: RAGING_GOOSE[/] logged in with entity id 139 at ([world]219.8264092519976, 64.0, 879.7106476179599)
    [20:34:42] [Server thread/ERROR]: Encountered an unexpected exception
    java.lang.RuntimeException: invalid distance too far back
    at org.bukkit.craftbukkit.v1_8_R3.chunkio.ChunkIOProvider.callStage1( ~inecraft_server.jar:git-Bukkit-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.chunkio.ChunkIOProvider.callStage1( ~inecraft_server.jar:git-Bukkit-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.util.AsynchronousExecutor$Task.init( ~inecraft_server.jar:git-Bukkit-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.util.AsynchronousExecutor$Task.initAsync( ~inecraft_server.jar:git-Bukkit-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.util.AsynchronousExecutor$ ~inecraft_server.jar:git-Bukkit-18fbb24]
    at java.util.concurrent.ThreadPoolExecutor.runWorker( ~[?:1.8.0_144]
    at java.util.concurrent.ThreadPoolExecutor$ ~[?:1.8.0_144]
    at [?:1.8.0_144]
    Caused by: invalid distance too far back
    at ~[?:1.8.0_144]
    at ~[?:1.8.0_144]
    at ~[?:1.8.0_144]
    at ~[?:1.8.0_144]
    at net.minecraft.server.v1_8_R3.NBTCompressedStreamTools.a(SourceFile:95) ~inecraft_server.jar:git-Bukkit-18fbb24]
    at net.minecraft.server.v1_8_R3.NBTCompressedStreamTools.a(SourceFile:71) ~inecraft_server.jar:git-Bukkit-18fbb24]
    at net.minecraft.server.v1_8_R3.NBTCompressedStreamTools.a(SourceFile:67) ~inecraft_server.jar:git-Bukkit-18fbb24]
    at net.minecraft.server.v1_8_R3.ChunkRegionLoader.loadChunk( ~inecraft_server.jar:git-Bukkit-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.chunkio.ChunkIOProvider.callStage1( ~inecraft_server.jar:git-Bukkit-18fbb24]
    ... 7 more
    [20:34:42] [Server thread/ERROR]: This crash report has been saved to: /aternos/server/./crash-reports/crash-2018-03-01_20.34.42-server.txt
    [20:34:42] [Server thread/INFO]: Stopping server
    [20:34:42] [Server thread/INFO]: [Shopkeepers] Disabling Shopkeepers v1.86
    [20:34:42] [Server thread/INFO]: [WorldEdit] Disabling WorldEdit v6.1;no_git_id
    [20:34:42] [Server thread/INFO]: [ClearLag] Disabling ClearLag v2.9.7
    [20:34:42] [Server thread/INFO]: [ClearLag] Clearlag is now disabled!
    [20:34:42] [Server thread/INFO]: Saving players
    [20:34:42] [Server thread/INFO]: RAGING_GOOSE lost connection: Server closed
    [20:34:42] [Server thread/INFO]: RAGING_GOOSE left the game.
    [20:34:42] [Server thread/INFO]: Saving worlds
    [20:34:42] [Server thread/INFO]: Saving chunks for level 'world'/Overworld
    [20:34:44] [Server thread/INFO]: Saving chunks for level 'world_nether'/Nether
    [20:34:46] [Server thread/INFO]: Saving chunks for level 'world_the_end'/The End

    I have found that this could be, because of the fact that is is not set to "online-mode" it told me in log to set it to online true in file yet I don't know how to get to it.


    I'm pretty sure that this is where the error is occurring,

    40[21:04:19] [Server thread/ERROR]: Encountered an unexpected exception
    41java.lang.RuntimeException: invalid distance too far back
    42 at org.bukkit.craftbukkit.v1_8_R3.chunkio.ChunkIOProvider.callStage1( ~[minecraft_server.jar:git-Bukkit-18fbb24]
    43 at org.bukkit.craftbukkit.v1_8_R3.chunkio.ChunkIOProvider.callStage1( ~[minecraft_server.jar:git-Bukkit-18fbb24]
    44 at org.bukkit.craftbukkit.v1_8_R3.util.AsynchronousExecutor$Task.init( ~[minecraft_server.jar:git-Bukkit-18fbb24]
    45 at org.bukkit.craftbukkit.v1_8_R3.util.AsynchronousExecutor$Task.initAsync( ~[minecraft_server.jar:git-Bukkit-18fbb24]
    46 at org.bukkit.craftbukkit.v1_8_R3.util.AsynchronousExecutor$ ~[minecraft_server.jar:git-Bukkit-18fbb24]
    47 at java.util.concurrent.ThreadPoolExecutor.runWorker( ~[?:1.8.0_144]
    48 at java.util.concurrent.ThreadPoolExecutor$ ~[?:1.8.0_144]
    49 at [?:1.8.0_144]
    50Caused by: invalid distance too far back
    51 at ~[?:1.8.0_144]
    52 at ~[?:1.8.0_144]
    53 at ~[?:1.8.0_144]
    54 at ~[?:1.8.0_144]
    55 at net.minecraft.server.v1_8_R3.NBTCompressedStreamTools.a(SourceFile:95) ~[minecraft_server.jar:git-Bukkit-18fbb24]
    56 at net.minecraft.server.v1_8_R3.NBTCompressedStreamTools.a(SourceFile:71) ~[minecraft_server.jar:git-Bukkit-18fbb24]
    57 at net.minecraft.server.v1_8_R3.NBTCompressedStreamTools.a(SourceFile:67) ~[minecraft_server.jar:git-Bukkit-18fbb24]
    58 at net.minecraft.server.v1_8_R3.ChunkRegionLoader.loadChunk( ~[minecraft_server.jar:git-Bukkit-18fbb24]
    59 at org.bukkit.craftbukkit.v1_8_R3.chunkio.ChunkIOProvider.callStage1( ~[minecraft_server.jar:git-Bukkit-18fbb24]
    60 ... 7 more
    61[21:04:19] [Server thread/ERROR]: This crash report has been saved to: /aternos/server/./crash-reports/crash-2018-03-01_21.04.19-server.txt

  • Oh well, i saved the world and went on to generate a new one everything works fine on it. So yeah it is the world that's broken. I have tried deleting the player data but it didn't do much, any ways thanks for your help though.

  • Roman

    Closed the thread.