why did placeholderAPI got removed ? and what are the alternatives for 1.18/1.19 ?